読者です 読者をやめる 読者になる 読者になる

Shut the fuck up and write some code

グダグダ言わずにコードを書きたいブログ

iOSシミュレータ/iOS7にアプリがインストール出来ない

軽くハマったのでメモ。


iOSアプリでiOS7でテストする必要が出てきたので、Xcode5-DB3でビルドして、iOSエミュレータでiOS7を指定して起動させようとしてみたところ、ポップアップが出て止まります。

f:id:very_tired:20130712143225p:plain

アプリがインストール出来ないだと!他のバージョンで試してみるとiOS5&6系では問題なく動く。iOS7だけ止まる。


あれや試してた結果、IdentityのBuildの指定が空白だったので

f:id:very_tired:20130712143507p:plain


値を適当に入れてみるとインストールされ起動できました。

まあ値は入れておくべき箇所なんだろうけど、他のバージョンだと動くってのがイマイチ納得出来ない・・・解決したからいいか。


絶対に挫折しない iPhoneアプリ開発「超」入門【iOS6対応版】
高橋 京介
ソフトバンククリエイティブ
売り上げランキング: 1,157